NixOs doesn't boot anymore from on encrypted disk

Hi just hard rebooted after a while of hibernations and it’s not asking me for a passprase to decrypt the hard disk and is instead falling in a heap using any of the 4 versions I have available to me. (They all return the same result)

I’m guessing I need to do hand to hand combat in the trenches with grub at this stage!

loading module dm-snapshot…
loading module dm_mo…
runing udev…
Starting version 249.4
Passphrase for /dev/disk/by-uuid/uuid-here; [ 1.558595] hid (null): invalid report_size 2056

then a few more invalid report_sizees all from “item 0 4 1 7 parsing failed”

Any ideas how I breath some live back into this thing? Do I need to run a disk check? Have I got a bad “sector” on my SSD?

I haven’t recently changed any settings related to disk or bootup. I have garbage collected recently before updating as my boot partition is only 100Mb.

If it helps my setup is pretty much this:

(not that I can get into my hard disk any more. But it is very secure. Sigh)

I had a similar scary moment a couple of weeks ago when the laptop’s keyboard started dying – the arrow keys were OK so I could choose generations on boot etc., but some letter keys (needed for the correct disk password) stopped working.

Good times.

It’s not even getting to asking me a password. Seems very unhappy. I would be happy to have a keyboard problem. I’ve stuck in a usb with nixos iso on but that seems unhappy too. Doesn’t want to boot up even when I tell it to copy itself to memory.
Edit: Windows partition is working fine :frowning:

Is the only answer to delete the partition and start again? Does nixos make a habit of commiting suicide? Is it likely worse due to using encryption - should that be avoided?

Another try would be to use an Ubuntu ISO and try to decrypt from there.
But then again that should’ve worked with the NixOS ISO as well.
The internal harddrive shouldn’t be involved when booting from a live ISO.

My liveusb was corrupted. I can now boot up from liveusb and mount the encrypted drive which is cool.
But I still don’t really understand why nixos doesn’t want to boot. Seems like all is well with the disk.

I really don’t know enough about Nixos but maybe you can repair or reinstall it?
It should be reproducible after all ( Captain Obvious to the rescue;)

since you’ve been able to decrypt the disk manually, you need to save the logs, and check if there is something in them to tell you what’s wrong

to troubleshoot you can rebuild the system and check if it boots after that.
If it does, than it’s a bug and you should upload logs for pro’s to investigate it(no guaranties someone will/succeed)

If it doesn’t boot after fresh rebuild i would suggest to switch to systemd-boot it’s much simplier and in my experience less buggy than grub

Also it would be better to know what changes you’ve made to the config between the last successful boot and the first failed one.

1 Like

my bad, it seems you already use systemd-boot in your config

I’m guessing I need to do hand to hand combat in the trenches with grub at this stage!

why do you suspect that you need to do something with grub than?
Is it possible that you switched to systemd-boot in the config and forgot to switch to uefi mode? so it boots from legacy boot grub2?

Check the logs is a good idea. After reinstalling from the liveusb it worked fine. The only damage done was to my Saturday. I’ll see if there’s any smoking guns in the logs. I haven’t changed much recently, but then again it’s been a while since a true reboot too.

have you changed a major version since the last reboot?