NixOS install behaving strangely

Hello, first time nixOS user here.

I recently tried to install NixOS, several times, and I’ve finally got it working (sort of). The first install I did crashed a lot. The second crashed a lot, and I also noticed that none of my settings would persist between boots, and the file system didn’t produce anything so there wasn’t a Desktop, Downloads, etc. I’ve got that solved now. The internet connection is still being weird though, and it’s extremely snappy on my windows machine so I’m not sure why. The initial boot shows a bunch AE_NOT_FOUND errors, among other errors but I’m not sure if that matters since the environment loads up after that.

I’m also running into an issue trying to build a rust project, and the repository has a shell.nix in the root to build the dependencies. I land into a new nix shell and run cargo build but get a segfault while cargo tries to build the dependencies of the project, but I don’t run into that issue on my m1 macbook air using nixpkgs. The same problem caused my previous installations of nixOS to crash the computer anytime I ran a cargo command. Oddly enough, if I run cargo build enough times on my current installation, it fails with segfaults in different packages until it eventually builds???

Anyone know what’s going on?

Sounds a lot like a hardware problem, faulty memory being the first contender. Running memtest86+ would be a good start.

After running memtester and everything coming back ok; I ended up updating my bios, which happened to be roughly 2 years out of date. Everything seems to be running smoothly now, might just nuke and reinstall nixOS just incase it interfered with the installation at all.
Appreciate your time! :slight_smile: