NixOs installer fails


Today, 15th October, I downloaded the gnome based NixOs 22.05 installer with the intention to start a fresh install on a physical machine.

I already have a working install in a VM.
(Based on a NixOs 22.05 download of 22/07/2022)

Right at the start of the latest installer menu it complains that the machine is not connected to the internet. Weird. I can browse the internet from within the live iso.

Next I tried to install it in a VM.
Same issue. Installer thinks it is not connected. Browsing is possible.

What is wrong ?

I still have the July download and will try that as well.



That is strange. My July download fails as well. That is:


Looking into log, pasted to, I found alot of these errors:

2022-10-16 - 11:44:56 [6]: [PYTHON JOB]: “nixos-install: warning: error: unable to download ‘’: Couldn’t resolve host name (6); retrying in 269 ms”

Following the link resulted a “404”.

The machine is on a wired connection.

Next, again I tried on a Virtualbox VM.
Similar issue.

Any one an idea?

best regards


One thing I found is that the NixOs installer does not like openDNS or my specific settings.
After changing the DNS settings to googles and, the installer happily started.

One other change, I disconnected the 4 drives which will be the zfs/raid tank/storage.

Now I am stuck with a install issue wrt grub/Blocklist.



New machine, new install.

Again I see issues that the NixOs installer cannot resolve the hostname wrt

I have no clue where this comes from and could need some help.

BTW, I am using the GUI installer.



could you share the output of ip a, ip r and cat /etc/resolv.conf ?

Thanks for the message.
Apologies not replying sooner.

I ran the installer via the command line.
Initially this failed as well. The second time it ran fine.
Somehow it seems the machine has a stuttering internet connection.

Since I have a working install I am not willing to reproduce. Possibly I have another ssd to try.



1 Like