NixOS wont boot goes back to boot selection screen

Hey guys I’m having an issue that I’m not sure how to resolve. On one of my computers NixOS boots just fine. on another pc I get to the NixOS boot screen (the one with the countdown) and whether I select an option or let the counter run out the os will not boot. It just goes back to the bios boot selection screen. I have reflashed the usb several times although I know it works just fine on another computer.

The computer that wont boot NixOS will boot ubuntu and linux mint flash drives just fine. I am using rufus to flash the drives using iso mode.

Update: Secureboot is disabled, I have uefi, and I am using 23.05
I have also tried secure boot enabled I get the same result.

This is a mini amd pc if that makes any difference. it has 16gb of ram, Athlon Silver 3050e and vega 3 graphics. Although this hasn’t been an issue for any other distro.

What ISO are you attempting to boot? If not 23.05: try 23.05?

Do you have UEFI? SecureBoot enabled? It would help to gather this information to triage this issue.

Secure boot is disabled, I do have uefi, and I am using 23.05