No usable version of libssl was found

I am trying to run an unpatched binary on NixOS using nix-alien the program is Stardrop a Stardew Valley mod manager. The problems is that when I try to run the program with nix-alien it gives me an error that “No usable version of libssl was found”. I couldn’t find a libssl package so I tried with OpenSSL and openssl_1_1 but that didn’t solve the problem. Is there something else I can try to fix the problem?

1 Like

Have you tried with instead of just openssl?

I can’t find an package.

openssl is the package, dev is the output with the library files

That doesn’t solve the issue.

1 Like

I haven’t used nix-alien, so my only other thought is whether the binary needs the process documented in nix-alien’s limitations section (but I imagine you might already trying this).

Perhaps @m45t3r will know :slight_smile:

SMAPI which is a mod loader for Stardew Valley also can’t detect libssl so it can’t check for updates for mods. The only solution I found is to start the game with steam-run witch fixed the error.