Nwg-look refuses to install no matter how i try to install it

I have absolutely no idea how to fix this. I just installed nixos today and wanted to change my gtk settings in a way that didn’t involve searching for the exact names of fonts and stuff like that, and given the fact that lxappearance doesn’t seem to want to work on hyprland(i tried), I thought nwg-look would be a better option.

I have tried everything I can to install this thing. I can’t figure out how to build this thing from source, as it requires packages that I can’t seem to find. Since I’m on unstable, I tried nix-env -iA nixos.nwg-look which is what it says on the package details on search.nixos.org, but that didn’t work either. Eventually, i tried to put pkgs.nwg-look in configuration.nix, spelt exactly how it should be, completely overriding any and all possible points of failure with the package manager. Not only did that not work, but it suggested I misspelled nwg-dock, indicating it had no idea what package I was looking for.

I’m sorry if this is such a noobish-question, but I’m at a loss of ideas. I wish I had logs to provide for all of you, but journalctl didn’t give me anything. So, does anyone know how I could possibly fix this?

What is the output of sudo nix-channel --list, nwg-look is not in the stable branch yet.