Override ruby in riemann-tools


I’m trying to run run riemann on my nixos-18.03 box. However I discovered that riemann-tools requires ruby-2.3.
and I’m not sure how to force the usage of the “correct” ruby version.

Can someone help?

I’ve now opened an issue rieman-tools not installable · Issue #41913 · NixOS/nixpkgs · GitHub on github


I tried with overlays but without success, ruby-2.4 is used.


{ config, pkgs, ... }:

	riemannOverlay = self: super: {
		riemann-tools = super.riemann-tools.override {
			bundlerEnv = super.bundlerEnv.override {
				ruby = self.ruby_2_3;
{  nixpkgs.overlays = [

Did the fix at Riemann-tools: 0.2.6 -> 0.2.13 by manveru · Pull Request #41927 · NixOS/nixpkgs · GitHub work for you?

It’s not yet available in the nixos-18.03 channel.

Yeah, but you can use it even without having it in a channel, it’s pretty quick to build.

    (import (fetchGit {
      url = https://github.com/NixOS/nixpkgs;
      ref = "master";
    }) {}).riemann-tools;

The package builds correctly, however it seems the package name in default.nix has not been updated to 0.2.13.

Is it intentional?

No, I must’ve missed that since I only updated the Gemfile… I’d be happy about a PR for that :slight_smile:

done PR #42040