PipeWire No Sound

I wanted to try PipeWire. I’m using a fairly standard configuration that I got from the Wiki:

  security.rtkit.enable = true;
  services.pipewire = {
    enable = true;
    alsa.enable = true;
    alsa.support32Bit = true;
    media-session = {
      enable = true;
    pulse.enable = true;
  hardware.pulseaudio.enable = false;

I also tried it without rtkit. I first tried it with Linux Kernel 5.10.* and now with 5.15.*, but it seems that while PipeWire itself is working fine, no application can connect to its server.

$ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 34
Server Protocol Version: 35
Is Local: yes
Client Index: 35
Tile Size: 65472
User Name: tifa
Host Name: nixos
Server Name: PulseAudio (on PipeWire 0.3.39)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: @DEFAULT_SINK@
Default Source: @DEFAULT_SOURCE@
Cookie: 624f:dee0

If I open, for example, Gnome Sound, I can’t select any output or input. No application can produce any sound.

With alsamixer I can select my sound card and fiddle with the settings just fine, but it doesn’t change the fact that my system has no sounds.

journalctl reveals 0 errors and pipewire and pipewire-pulse are starting and running just fine.

Just when I was about to give up for the night… Pipewire doesn't actually recognize any Sound outputs (devices) - #10 by redjar - Ask Fedora

Starting the pipewire-media-session manually and sound suddenly works. I’ll have to create a PR or investigate why this isn’t done per default. At least update the wiki

EDIT: Seems like I just happened to try it at a bad time. The update for PipeWire that adds the media session is only 17 days old and just didn’t make it into unstable yet pipewire-media-session: init at 0.4.0 · NixOS/nixpkgs@b65f74f · GitHub