Plasma crashing on startup

Been dealing with this problem for a few weeks now and haven’t been able to figure it out.

I have autologin with sddm setup so that plasma logs into a wayland session. This used to work but something happened where now if I boot into NixOS, the plasma splash screen will show for a few seconds, and then it will crash to a TTY. If I run sddm from the tty it will show my login screen and if I login, it crashes. This happens for both X11 and for wayland-session. So far I’ve been able to work around this by running dbus-launch startplasma-wayland and then I can use plasma just fine. However I would like it to just work how it is supposed to.

Here’s my journalctl

Could you reproduce the problem just once and then grab a journalctl --boot from the tty you crash to? There are at least 4 instances of sddm starting in these logs, I’m not sure where exactly the logs of the failing run will be.

journalctl --user -t xsession would be helpful too. Did you modify the plasma session script at all? It looks like it successfully boots in at least one flow, and then immediately closes (without crashing, as if it forked off or something).

FWIW, for me as well sddm have been crashing occasionally for the past month or so. I didn’t try to investigate though.

Sure thing! Thanks for helping. No I didn’t modify the plasma session script. One of the plasma sessions did succeed, because i used the dbus-launch command I said in my first post to get into plasma to grab the journalctl log and make the post. In hindsight I realize I should have grabbed the journalctl before getting into plasma. My mistake!

Here’s journalctl --boot, grabbed before getting into plasma, grabbed from the TTY that I crashed to on boot.

journalctl --user -t xsession came up with --no entries--

Is this the same issue? [Solved] SDDM fails to launch plasma, sddm-helper exits with 1. / Newbie Corner / Arch Linux Forums

I.e., check your rcfiles for bash, zsh & co (and likely xinitrc and xsession).

I figured it out what was causing the problem! It was this line in my configuration.nix:
services.xserver.displayManager.defaultSession = "plasmawayland";

I’m not sure why this line would be causing so much trouble though. I’m not sure if this is a bug or a me problem.

Your mention of xsession led me down the right path!