Poetrynix flake (even minimal/vanilla) consistently produces stack overflow

When (for the first time) trying to migrate a python app’s poetry environment to a flake with poetry2nix, I ran into a strange problem:

> nix develop
warning: Git tree '/home/jeroen/devel/github.com/ppenguin/tst-poetry2nix' is dirty
[1 copied (148.4 MiB), 24.8 MiB DL] evaluating derivation 'git+file:///home/jeroen/devel/github.com/ppenguin/tst-poetry2nix#devShells.x86_64-linux.default'error: stack overflow (possible infinite recursion)

This happens even with a completely empty repo where a vanilla flake was produced with

nix flake init --template github:nix-community/poetry2nix

--show-trace doesn’t make a difference (I think the stack overflow occurs before a trace is produced?), so I have nothing to go on.

But anyway this is highly surprising, otherwise this is a perfectly robust NixOS system on which all other devShells and flake builds work without issues.

Any ideas?

Oh, there appears to be a regression in unstable that causes this! (Thanks @K900 on Matrix)
Setting the flake input to 23.05 solved it.