PRs in distress

SSH - Add crypot options.
Example ssh config after this PR:

  programs.ssh = {
    macs = [ "" "hmac-sha2-512" ];
    ciphers = [ "" ];
    kexAlgorithms = [ "" ];
  services.openssh = {
    macs = [ "" ];
    ciphers = [ "" ];
    kexAlgorithms = [ "" ];
1 Like

I have a not too big nodePackages fix for an issue which passes all tests possible, but every once in a while it reaches a merge conflict status… And what’s annoying even more is that running node’s takes about half a day (for me) and afterwards I have to cherry-pick only the relevant changes to the commit and discard the rest :disappointed:

Improvements to gitlab-runner module:

Fix for armv7l/aarch64 image builder:

BananchickPasha made a Pull Request to fix JetBrains Rider (that is currently broken on unstable).

The reviewer seems to be unavailable to handle this PR, can somebody check it ?


I have two PRs stuck for a long time:

This one is docs-only: crucial steps are missing from the manual in the instructions for nixos lustration. Someone else figured out a solution and posted it in an issue back in 2018, all I did was add the solution to the docs. The PR doesn’t seem to have had any attention yet. It could do with someone who is familiar with bootloaders having a look at whether there is a better way of doing it, and maybe suggesting some commentary for the new steps.

This one isn’t terribly important or complicated. A new package for the virtual ANS microtonal synthesizer. It’s been approved and seems to be waiting for a merge. However, as I have no means of testing the darwin version, it’s simply disabled, even though it would probably work. So perhaps someone with a Mac could test it there.

I wrote a package for ILSpy, but the reviewer demands building it from source, something I don’t need or have the time to do, so maybe someone else wants to pick it up?

I’d appreciate any other opinions on this PR:

Personally I don’t really want to merge it as is, but I would like some other people to either agree or disagree with that so we can proceed.

Hello, I’m trying to upgrade the broken Mesos package, currently failing because autoconfigure cannot find Python package google.protobuf and I don’t know how to fix that issue.

Thanks for any help!

1 Like

I’m trying to get the EC2 metadata fetcher to use IMDSv2. I have built imported and tested images on AWS EC2, but the script is also used by OpenStack and I’d really appreciate someone with an OpenStack setup testing that I didn’t break their compute services.

Also note that the script being changed runs in initramfs and uses busybox, so some of it is a bit subtle:

This is a very simple change but it has important consequences on the security of Nixpkgs. It would need feedback from security people because the maintainer and I are not confortable merging it.

This PR updates tdlib to 1.6.9, which is the minimum required by telega. This makes the Emacs Telegram client work on NixOS.

I could use a quick review of so I can get the updated version into 20.09 and finish my upgrade. Thanks!

I would appreciate if a darwin / macOS wizard could take a look at these two (same issue in both packages):

The version bump doesn’t seem to introduce any new failures, but a review has brought to light that it has always been failing on macOS because it wants to use a program called sips to manipulate its icon images.

Not sure if there’s a package containing sips that can be added to nativeBuildInputs on darwin, or whether we need to do some substituting, like this packages does:

I think this PR fairly important but it’s stuck because of an unknown issue with networkd/initrc. I’m not familiar with networkd and could use some help:

While a very reasonable improvement, this PR is blocking proper support for aarch64 on divnix/devos for alack of appropriate reviewer and/or merger:

1 Like

This PR has been stuck for a long time, it’s seen some amendments and positive comments already, but I’d like someone with merge rights to take a look and decide to pull the trigger - or reject it definitively so I can focus on just hacking it into my own config.

This PR adds a new service for xidlehook, an alternative to xautolock that, among other things, can be configured to not lock the screen when an application is fullscreened. Needs review from someone with knowledge of NixOS services. It’s relatively simple and a lot of it is copy pasted from the xautolock service.

Could use some help from someone with knowledge in

  • patching proprietary binaries designed to be installed in /opt
  • packaging Gnome/Gtk apps

There’s some description of the issues and things tried so far in the PR.

I tried to package the GNU Data Language (GDL), a drop-in replacement of the commercial Interactive Data Language (IDL) used in the field of astronomy and atmospheric science.

The problems include:

  • The built binary cannot find XWin or WXWidget
  • Some CI tests doesn’t pass