Rabbitmq needs a new maintainer

FYI: rabbitmq: Remove Profpatsch as maintainer by Profpatsch · Pull Request #134075 · NixOS/nixpkgs · GitHub

Maybe somebody who has effectively been updating it wants to step up add themselves to the package.

3 Likes

I’ll gladly be maintainer, since we’re using this in production.

So why does ryantm-bot not update it anymore?

5 Likes

I’m unsure, my best guess is a lexical sorting issue of the version numbers.

I opened an issue a while ago: rabbitmq stopped updating · Issue #268 · ryantm/nixpkgs-update · GitHub

1 Like

Lexical sorting can’t be the problem, right now it’s failing to updated to 3.9.3 from 3.9.1.

I’ll be maintaining after rabbitmq-server: bump & set new maintainer by turion · Pull Request #134443 · NixOS/nixpkgs · GitHub, but I can’t really promise to be up to date without a bot.

1 Like

Good news it started updating again: https://github.com/NixOS/nixpkgs/pull/134489

5 Likes

Thanks for your great work @ryantm!

1 Like