Raspberry PI 3B Issues/Freezing

Hi everyone!

I’m trying to run NixOS on my Raspberry PI 3B and it keeps freezing/giving me logs like:
sdhost-bcm2835 3f2020000.mmc: timeout waiting for hardware interrupt.
I/O error, dev mmcblk0, sector 1607192 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 2
It seems to only happen when I run nixos-rebuild switch but I don’t think it’s my nixos configuration.

I’ve tried running fsck on the SD card but I don’t really understand it’s output or how to use it yet. Not really a hardware person but still trying. This was the output:

λ [~] →  sudo fsck /dev/mmcblk0
fsck from util-linux 2.38.1
e2fsck 1.46.5 (30-Dec-2021)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/mmcblk0

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    e2fsck -b 32768 <device>

/dev/mmcblk0 contains `DOS/MBR boot sector; partition 1 : ID=0xb, start-CHS (0x1,5,5), end-CHS (0x4,215,19), startsector 16384, 61440 sectors; partition 2 : ID=0x83, active, start-CHS (0x4,215,20), end-CHS (0x3ff,254,63), startsector 77824, 60674048 sectors' data

Does anyone have any ideas on how I would go about fixing this?

I also encountered this message once.
The reason was that the boot partition was corrupted.

In my case, it got corrupted because of a too weak power supply when initially resizing the partition to the full size of the sd card.

Ah interesting. I’ll have to try reimaging the OS then to see if that fixes it.