Running shadow client on nixos

I am having trouble using shadow ( on the current nixos.

I am using this repository to setup shadow GitHub - cornerman/shadow-nix: Supporting Shadow under NixOS and use it in my config like this: nix/shadow.nix at 632282558dad4d17e7bfc6dc4ad8fb828b03098d · cornerman/nix · GitHub.

This has worked before but now suddenly stopped working. Now I am getting this error message when building my config:

Builder called die: Cannot wrap '/nix/store/z2rnjllg0f9anl3yhlhmzi9k8401cc27-shadow-preprod-8.0.10012/opt/shadow-preprod/shadow-preprod' because it is not an executable file
7 assertExecutable /nix/store/rpv22rg1gfn1rc72v4l3za40qx1wlq4y-hook/nix-support/setup-hook
41 makeShellWrapper /nix/store/rpv22rg1gfn1rc72v4l3za40qx1wlq4y-hook/nix-support/setup-hook
34 makeWrapper /nix/store/rpv22rg1gfn1rc72v4l3za40qx1wlq4y-hook/nix-support/setup-hook
1395 genericBuild /nix/store/gj6sb40881c9gyrrp3x2c84zcsmv0zq4-stdenv-linux/setup
2 main /nix/store/

I would appreciate any hint, how to fix this or where to look.

I solved it. The problem was that shadow has renamed the binary inside the AppImage. I have updated the shadow-nix repository.

1 Like