Services.kmscon keyboard repeat rate

I’m running NixOS unstable channel using services.kmscon in my configuration.nix like so:

  services.kmscon = {
    enable = true;
    hwRender = true;
    extraConfig = ''
      font-name=Source Code Pro Semi-Bold

But for whatever reason, kmscon doesn’t seem to be respecting the xkb keyboard repeat rate options? Regardless of what I change repeat-rate and repeat-delay to, the rate and delay do not change.

I believe I’m using the options correctly. You can see above that I’ve tried both kmscon.conf syntaxes for repeat rate and delay. The kmscon manual page states:

Keyboard input is done by libxkbcommon . This provides the same features as the X11 Keyboard System but without any dependencies on X11 libraries. See the –xkb-{option} options for ways to change the keyboard layout, model, repeat rates and more. For instance –xkb-layout=de changes the keyboard layout to German.

Is there something different about the way NixOS handles libkbcommon? What am I missing?

I also tried with services.kmscon.useXkbConfig = true; to no avail.