Shotwell not saving preferences

Hey everyone,

I could really use some help with Shotwell on NixOS 23.05. I’m having trouble getting Shotwell to save its preferences, like the watch picture library for changes and other settings (date format, etc.). I’ve tried a few things already, but nothing seems to be working.

First, I changed the permissions of the .local/share/shotwell and .config/shotwell folders to 777, hoping that would solve the issue. Unfortunately, no luck there.

I also made sure to add Shotwell to both the environment and packages sections in my “configuration.nix” file, just to be sure it’s properly integrated with NixOS.

If anyone has come across a similar problem with Shotwell on NixOS 23.05 or has any ideas on how to fix this preference-saving problem, I’d really appreciate your input. I’m open to trying out any suggestions you might have.

Thanks in advance

Try running Shotwell in the console or look at systemd journal if there are any errors.

But I am guessing you are missing programs.dconf.enable = true; in your NixOS configuration. It is expected to be set in desktop environments that expect to run GTK apps but I guess Plasma or whatever you use does not do that.

Also, I would advise against blindly changing permissions. That is fast way to get a hard-to-repair broken profile.

1 Like

Thank you for responding, but I’m confident that programs.dconf.enable = true; would be used primarily by GNOME-based desktop environments rather than Plasma?

Could you try it out anyway? As I understand, while this option is normally relevant to Gnome DE, GTK-based applications (which shotwell is) depend on it as well.

1 Like

That did the trick!


1 Like