Should the minimum required Nix version for Nixpkgs be 2.0?

Recently, the minimal Nix version was bumped to 2.0. There are several drawbacks to this:

  • It has only been 6 months since Nix 2.0 was initially released. This is a very aggressive timeline.

  • Users of less than 1 year will find their installations unable to support Nixpkgs.

  • Those users would solve this by trying to upgrade Nix. But this is now impossible using Nix 1 and the current HEAD of nixpkgs.

    $ nix-env -f -iA nix
    error: evaluation aborted with the following error message: ‘
    This version of Nixpkgs requires Nix >= 2.0, please upgrade:
  • By extension, you can not upgrade directly from NixOS 17.09 to 18.09.

The pros stated in the PR are “Placeholders are just too convenient,” but I understand there are likely others and would like to hear them. Please provide your thoughts and discuss whether this requirement should be kept or reverted before 18.09 is considered stable.


For now the best option is to first upgrade to 18.03. More discussion over here: Impossible to easily upgrade NixOS from <=17.09 to 18.09 · Issue #46387 · NixOS/nixpkgs · GitHub