Some installer and language issues for this user

Congratulations to the NixOS team for the graphical installer in 22.05.

Firstly there seems to be issues with installing NixOS 22.05 in VMWare and Virtualbox. The new graphical installer always hangs at 46% done. I did get it to complete in my host’s Gnome Boxes after it hung a bit at the same spot. The installer printed out a problem about starting osprober before continuing.

Second, the language in the Date/Time/Calendar is wrong in the Gnome install. My system is set to English - US but the date reads “2 de jun …” in the title bar and the drop down calendar says its “jeuves Junio 2 2022”. The actual calendar app is also showing the days and month in a different language as well. The words Week/Month/Year are, however, in English.

Thanks for bringing up these issues! Usually at 46% is when the nixos-install command is running, so while it seems to hang, it actually might take around 10-15 minutes to complete. I’m working on improving the logging so users can actually see that progress is being made during that step of the installation.

As for the language issue, is this in the live installation session or after install? Calamares has an option for choosing language and locale, and that modifies some system components (although still a bit finicky on GNOME/Wayland), so might be an issue with that

vlinkz,

Regarding the vm installs I mentioned, I let them run much longer than 15 minutes, probably over an hour.

The language issue is in the installed version, not the live CD. I might have believed that this was a Gnome issue but I’ve never had this occur before.

Over an hour is definitely an issue, although if the install failed it should crash and give an error log, so you’re right sounds like something must’ve frozen. I’ll test it in VMWare and Virtualbox to try to find the issue.

And for the language, can you post your configuration.nix file? Since this happened after installation I’m assuming that something in there must be specifying the incorrect language

I’d love to except I can’t figure out how to attach a text file here. The upload icon only takes certain picture files. Changing the extension on my nix file yielded complaints about a non-determinant size.

BTW, one more issue, when the screen blanks out it doesn’t display the login screen only a blank white screen. I must close the Boxes window and reopen it to display the login screen. This is not a typical behavior of Boxes. I’ve therefore set the screen blank to never.

Put the code into a code block:

```Nix
{ foo = “bar”; }
```

Becomes

{ foo = "bar"; }
1 Like
# Edit this configuration file to define what should be installed on
# your system.  Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running ‘nixos-help’).

{ config, pkgs, ... }:

{
  imports =
    [ # Include the results of the hardware scan.
      ./hardware-configuration.nix
    ];

  # Bootloader.
  boot.loader.grub.enable = true;
  boot.loader.grub.device = "/dev/vda";
  boot.loader.grub.useOSProber = true;

  networking.hostName = "nixos"; # Define your hostname.
  # networking.wireless.enable = true;  # Enables wireless support via wpa_supplicant.

  # Configure network proxy if necessary
  # networking.proxy.default = "http://user:password@proxy:port/";
  # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";

  # Enable networking
  networking.networkmanager.enable = true;

  # Set your time zone.
  time.timeZone = "America/Bogota";

  # Select internationalisation properties.
  i18n.defaultLocale = "en_US.utf8";

  i18n.extraLocaleSettings = {
    LC_ADDRESS = "es_CO.utf8";
    LC_IDENTIFICATION = "es_CO.utf8";
    LC_MEASUREMENT = "es_CO.utf8";
    LC_MONETARY = "es_CO.utf8";
    LC_NAME = "es_CO.utf8";
    LC_NUMERIC = "es_CO.utf8";
    LC_PAPER = "es_CO.utf8";
    LC_TELEPHONE = "es_CO.utf8";
    LC_TIME = "es_CO.utf8";
  };

  # Enable the X11 windowing system.
  services.xserver.enable = true;

  # Enable the GNOME Desktop Environment.
  services.xserver.displayManager.gdm.enable = true;
  services.xserver.desktopManager.gnome.enable = true;

  # Configure keymap in X11
  services.xserver = {
    layout = "us";
    xkbVariant = "dvorak";
  };

  # Configure console keymap
  console.keyMap = "dvorak";

  # Enable CUPS to print documents.
  services.printing.enable = true;

  # Enable sound with pipewire.
  sound.enable = true;
  hardware.pulseaudio.enable = false;
  security.rtkit.enable = true;
  services.pipewire = {
    enable = true;
    alsa.enable = true;
    alsa.support32Bit = true;
    pulse.enable = true;
    # If you want to use JACK applications, uncomment this
    #jack.enable = true;

    # use the example session manager (no others are packaged yet so this is enabled by default,
    # no need to redefine it in your config for now)
    #media-session.enable = true;
  };

  # Enable touchpad support (enabled default in most desktopManager).
  # services.xserver.libinput.enable = true;

  # Define a user account. Don't forget to set a password with ‘passwd’.
  users.users.xxxxx = {
    isNormalUser = true;
    description = "xxxxx";
    extraGroups = [ "networkmanager" "wheel" ];
  };

  # Allow unfree packages
  nixpkgs.config.allowUnfree = true;

  # List packages installed in system profile. To search, run:
  # $ nix search wget
  environment.systemPackages = with pkgs; [
  #  vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
  #  wget
    firefox
  ];

  # Some programs need SUID wrappers, can be configured further or are
  # started in user sessions.
  # programs.mtr.enable = true;
  # programs.gnupg.agent = {
  #   enable = true;
  #   enableSSHSupport = true;
  # };

  # List services that you want to enable:

  # Enable the OpenSSH daemon.
  # services.openssh.enable = true;

  # Open ports in the firewall.
  # networking.firewall.allowedTCPPorts = [ ... ];
  # networking.firewall.allowedUDPPorts = [ ... ];
  # Or disable the firewall altogether.
  # networking.firewall.enable = false;

  # This value determines the NixOS release from which the default
  # settings for stateful data, like file locations and database versions
  # on your system were taken. It‘s perfectly fine and recommended to leavecatenate(variables, "bootdev", bootdev)
  # this value at the release version of the first install of this system.
  # Before changing this value read the documentation for this option
  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
  system.stateVersion = "22.05"; # Did you read the comment?

}

There’s your issue, seems like the secondary locale selected was Columbian Spanish. If you want everything to just be English, delete this section from the config and rebuild

Thanks for the troubleshooting help! Deleting the section worked, now in all english.

1 Like

I have an update.

After deleting the referenced entries in the locale section of the configuration.nix file as described above, after one or two reboots the file restored itself, giving the system the incorrect language again. As an experiment I tried editing all the above from “es_CO” to “en_US” instead of deleting them. So far, so good.

Hosted by Flying Circus.