SSH daemon won't start until plasma login

I have openSSH server enabled on my desktop via

  services.openssh.enable = true;
  services.openssh.forwardX11 = true;

And a dm and de

  services.xserver.displayManager.sddm.enable		= true;
  services.xserver.desktopManager.plasma5.enable	= true;

But it seems that the ssh server will only start once I’ve logged in through the dm.

Is this an issue with sddm?
Or is there some way I can guarantee that ssh will start at boot and not first login ?

The Issue was actually that I was using KDE NetworkManager to manage my wifi connection.
After configuring wpa_supplicant instead, the problem disappeared.