Stop auto-adding printers

In past distro’s with Gnome, I would disable the auto-adding of network printers by disabling the cups-browsed.service unit. However, with my new NixOS install, it’s not working. I have it disabled, but printers keep showing up in my settings. I use a large shared network and there are lots of printers on the network. My config is: = {
    cups-browsed = {
      enable = false;
      restartIfChanged = false;

And the service show’s masked:

[root@stanton:/etc/nixos]# systemctl status cups-browsed
○ cups-browsed.service
     Loaded: masked (Reason: Unit cups-browsed.service is masked.)
     Active: inactive (dead)

Is there something else that is adding these printers?