SVN doesn't want to store password

I cannot figure out how to make SVN store the password. Googling around, it seems to be an issue in general but all suggested solutions didn’t work on NixOS for me.

AFAIK SVN passwords are stored in a keyring, when you have plaintext passwords disabled in your SVN config.

Do you have a keyring manager enabled?

Depending on your desktop configuration you might want to use services.gnome.gnome-keyring.enable.

If you have KDE Plasma enabled, KWallet is enabled by default and used as the keyring manager.

I am using gnome-keyring, yes.

Are there any SVN passwords saved in your keyrings?
What does your SVN config file look like?

No SVN password saved so far.

I don’t have anything fancy in there. I tried to set the following options

password-stores = gnome-keyring
store-passwords = yes
store-auth-creds = yes

under the [auth] section in ~/.subversion/config but that didn’t do anything unfortunately.