System suddenly stopped booting. Should I reinstall?

I had some issues with apps freezing, even though the resources are not fully utilized for a while. An app reported lack of free space on the root partition. I ran the garbage collector, but it only removed 500MB. I have 120GB root partition and it was never more than half full after running the garbage collector.

I tried rebooting the computer, but the boot gets stuck. Originally it would only show white cursor on black background, now it goes all the way to checking user groups and then gets stuck.

The NixOS live USB seems to be working fine, even though Fedora live ISO crashed on me. I tested RAM and disc (SMART test) and they appear to be fine. Do you think I should reinstall? I suspected

It sounds like you’re out of disk space. You say it was never more than half full but all these symptoms would be explained by being out of disk space.

I have been out of space before and never experienced any issues like this.

how much of it is free though

also have you tried finding what is consuming space? du -sh around

It was indeed because of lack of free space on the root partition. *I fixed it by removing one item from /nix/store.

I previously ran out of space and could boot with no problem. Also, after reboot, the nix grbage collector was suddenly able to remove 65GB, where as before the reboot it was unable to remove anyting.

Thanks for the help.