Third monitor stopped being detected

I have 3 monitors 2 Dell S242HGF and 1 Dell E2422H. About a week ago the E2422H monitor stopped being detected. It shows up as disconnected with xrandr and nvidia-settings.

I’ve tried plugging it into my laptop and swapping the cables and ports around so its (probably) not a hardware issue. Rolling back to previous generations or building with older configs doesn’t seem to do anything.

Even more strange is that it will occasionally either partially or completely start working again for one boot when I try fixing it. For example:

  • it showed as connected in xrandr and nvidia-settings but still had no video
  • rolled back to a previous generation and it worked fine until the next boot

I had similar issues when displays were running too high of a refresh rate.
e.g:

  • if had 1 display at 144hz and 2 others at 120hz => issues
  • if had 1 display at 120hz and 2 others at 60hz => no issue

I’ve noticed monitors settings often get reset when nixos-rebuild switch.
I ended up storing a .config/monitors.xml to keep things consistent and as backup (for x11).

Well it seems to have started working again. No idea what caused it to be fixed as I didn’t do anything.