Thunderbird 102 on NixOS 22.11?

Can someone help me to understand why the package search lists “thunderbird” version 102.6 but on two NixOS 22.11 machines Thunderbird 91.5 is installed.

And when I click on “source” in the package search, why do I land at the firefox nix file instead of one of this files?

nixos-rebuild switch --upgrade does not help.

Have you tried actually doing sudo nix-channel --update, rather than depending on nixos-rebuild --upgrade? nixos-rebuild --upgrade only affects root’s nixos channel, and I have no idea what it even does if you run it without sudo (say, with --use-remote-sudo).

As for why the code link seems to go to the wrong place, it’s because thunderbird reuses firefox’s wrapping code.

Also, it might be unrelated but make sure to actually close all the instances of thundebird : at some points I was upgrading chromium (even trying with flake) but it was apparently failing… in fact I had the good version installed (as I could check in the which command) but the issue was that it was detecting an old background chromium daemon, and it was just asking the daemon to spawn a new window… so the new window was running an old version.

1 Like

Thank you both!

Thunderbird was not running during upgrade. I now tried as user root:

nix-channel --update
nixos-rebuild switch
nixos-rebuild switch --upgrade

After that, Thunderbird is still version 91:

$ thunderbird --version
 Thunderbird 91.11.0

No matter under which user it is started, root or other. Same after reboot.

Output of nix-channel:

$ nix-channel --list
$ sudo nix-channel --list

Maybe there is an implicit “skip” option to skip package upgrades that are not save or need a migration? Like IgnorePkg in Arch’s /etc/pacman.conf.

Any ideas what else I can do to debug this?

This wouldn’t be possible in nixos’ architecture.

Is the nixos-rebuild switch actually succeeding?

Good thoughts, but yes, I think so:

# nixos-rebuild switch 
building Nix...
building the system configuration...
activating the configuration...
setting up /etc...
reloading user units for gdm...
reloading user units for jakob...
setting up tmpfiles
# echo $?

Exactly the same output with --upgrade or after nix-channel --update.

does nix-env -q show thunderbird?

nix-env -q as root shows no output and exit status is 0. As user jakob, it only shows two other programs that I installed with nix-env --install.

What does which thunderbird say? That would give a clue of what’s actually installing it.

Also, you could try running /run/current-system/sw/bin/thunderbird just to check that it is in fact the correct version.

$ which thunderbird 
$ /run/current-system/sw/bin/thunderbird --version
 Thunderbird 91.11.0

Same for user root.

… when started as GUI application, it also says version 91.

It’s so weird that I seem to be the only one who have trouble with upgrading thunderbird. At two independent NixOS machines…

Then either a) your config is flake, and you never mentioned that, or b) you’re pinning thunderbird in your configuration somehow.

Sorry if this is way off, but in all the examples you’re posing you’re doing nixos-rebuild without sudo. Your example with nix-channel --list showed you do not have any channels with your logged in user, but you do with the root user. If you run sudo nixos-rebuild switch that will run it as the root user and find the correct channel the root user has configured.

Root’s channels are available to all users, so that shouldn’t be the issue. Also, given that the rebuild is succeeding, he must either be running it as root or with --use-remote-sudo, probably with an alias.

Please post the output of nix-info -m.

Your channel is showing nixos-21.11 instead of nixos-22.11.

Please try updating your channel with sudo nix-channel --add nixos.


:man_facepalming: how did I misread that as 22.11…

Oh man! 21.11 vs. 22.11 – I never noticed the difference!! Sorry everyone for the headache and thank you all for the help!

I installed both machines from an older USB stick :man_facepalming: And because the package search only shows channels 22.05 and 22.11, I always was sure that I’m on 22 .11.