Troubleshooting package/derivate installation in NixOS


I’m trying to install the gns3-server by adding entry to my /etc/nix/configuration.nix file.
However after using command: sudo nixos-rebuild switch I’m receiving this kind of error:

ERROR: Could not find a version that satisfies the requirement py-cpuinfo==7.0.0 (from gns3-server)
ERROR: No matching distribution found for py-cpuinfo==7.0.0
builder for '/nix/store/8wq3kq1hk014vhn35s1al3w0fnw3naaa-python3.8-gns3-server-2.2.18.drv' failed with exit code 1

At this moment I’m not sure how to proceed with troubleshooting, is there a need to tinker the package?

I have found that code on GitHub have added the “dependency”

propagatedBuildInputs = with python.pkgs; [
aiohttp-cors yarl aiohttp multidict setuptools
jinja2 psutil zipstream sentry-sdk jsonschema distro async_generator aiofiles
prompt_toolkit py-cpuinfo

Can you point me in the direction of where to find information so I might fix it myself?

I have wrote this overrideAtrr:

(gns3-server.overrideAttrs (oldAttrs: rec {
      postPatch = ''
        substituteInPlace requirements.txt \
        --replace "aiohttp==3.6.2" "aiohttp>=3.6.2" \
        --replace "py-cpuinfo==7.0.0" "py-cpuinfo>=7.0.0"

which solved the problem additionally i have created pull request.

The issue is solved.