Trying to use poetry on a python repo

Hi, I’m trying to use the tortoise-tts-fast repo via a flake. The repo suggests creating an environment via poetry, so I created the flake:

  inputs = {
    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
    flake-utils.url = "github:numtide/flake-utils";
  outputs = { self, nixpkgs, flake-utils }:
    flake-utils.lib.eachDefaultSystem (system:
      let pkgs = import nixpkgs { inherit system; };
      in with pkgs; {
        devShells.default =
          mkShell { packages = [ python310 poetry ]; };

And then, after the direnv has been activated, I tried poetry install and poetry shell; both commands worked. When I try to issue one command that uses the library, I get:

OSError: cannot open shared object file: No such file or directory

Could you explain the problem I’m facing here?

Other approaches I tried

  • I tried using mkPoetryEnv instead, I had to patch a lot of packages that required build inputs, but then met an inscrutable error. Although I’m curious about this, I would prefer avoiding it: I’d like to be able to ‘just try’ a repo, and package it correctly later if it’s needed.
  • I tried exporting paths in hooks to make libstdc++ visible, with no avail.

I’m also having this issue; I hope it can be resolved