Unable to build Helm 3.5.0

I’m trying to update the Helm version in nixpkgs to v3.5.0, but I’m running into the following build error when attempting to do so:

helm.sh/helm/v3/cmd/helm imports
        k8s.io/client-go/plugin/pkg/client/auth imports
        k8s.io/client-go/plugin/pkg/client/auth/azure imports
        github.com/Azure/go-autorest/autorest imports
        github.com/Azure/go-autorest: module github.com/Azure/go-autorest@latest found (v14.2.0+incompatible, replaced by github.com/Azure/go-autorest@v13.3.2+incompatible), but does not contain package github.com/Azure/go-autorest

I’m able to produce the error if I manually clone the Helm repo and checkout tag v3.5.0 and then do a make build. However, if I then perform a go mod tidy I’m able to reproduce that same error

sounds like an upstream issue, I would make an issue with them stating that the 3.5.0 release can’t be built using normal go conventions

EDIT:
already exists: Trouble building 3.5.0 · Issue #9239 · helm/helm · GitHub

thanks, I wanted to confirm here before posting in issue in Helm, but looks like someone else beat me to it.

1 Like

@jonringer hey do you know where the code that defines buildGoModule is? I’m trying to get a better understanding of how it works so I can help debug the issue; I’ve tried searching for it but I’m having no luck so far

Should live in pkgs/development/go-modules/generic/default.nix:

$ git grep "buildGoModule ="
pkgs/top-level/all-packages.nix:    buildGoModule = buildGo114Module;
pkgs/top-level/all-packages.nix:    buildGoModule = buildGo114Module;
pkgs/top-level/all-packages.nix:  buildGoModule = buildGo115Module;
$ git grep "buildGo115Module ="
pkgs/top-level/all-packages.nix:  buildGo115Module = callPackage ../development/go-modules/generic {
1 Like

thanks, I found the relevant code for the “buildGoModule” here nixpkgs/default.nix at a884b2182243cb2ec998e638c98ddfac58c2f812 · NixOS/nixpkgs · GitHub

Looks like the issue went away when the dependencies were updated in Helm 3.5.2.