Unable to find dependencies while building cmake project

I’m currently trying to build the xembedsniproxy without having to add the whole plasma workspace.

To do so, I’ve created the following derivation:

{ 
  stdenv, fetchFromGitHub,
  cmake, qt5, xorg
}:

stdenv.mkDerivation rec {
  name = "xembedsniproxy";
  version = "5.17";

  src = (fetchFromGitHub {
    owner = "KDE";
    repo = "plasma-workspace";
    rev = "Plasma/${version}";
    sha256 = "1dmyh2gxrkk3pyma70q142pma3263fmfjaydqfhsdakh7439njb1";
  } + "/xembed-sni-proxy");

  nativeBuildInputs = [ cmake ];
  buildInputs = [
    qt5.qtbase
    xorg.libxcb
  ];
}

Despite I added libxcb to buildInputs I get the following message:

CMake Error at CMakeLists.txt:6 (find_package):
  By not providing "FindXCB.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "XCB", but
  CMake did not find one.

  Could not find a package configuration file provided by "XCB" with any of
  the following names:

    XCBConfig.cmake
    xcb-config.cmake

  Add the installation prefix of "XCB" to CMAKE_PREFIX_PATH or set "XCB_DIR"
  to a directory containing one of the above files.  If "XCB" provides a
  separate development package or SDK, be sure it has been installed.

I’ve tried to put all the xcb stuff I’ve found using nix search, but I still have this issue. Any ideas ?

Maybe our xcb needs an update (https://xcb.freedesktop.org/#news 1.13.1 -> 1.14) - try that and try to add xorg.xcbproto as well.

Tried it, didn’t work either

Have you tried updating them as well?

I will try, but I don’t understand why it would be that ? Since we do use Plasma 5.17 and that xembedsniproxy is currently built within the plasma-workspace derivation currently wouldn’t it mean that all dependencies are available in current nixpkgs ?

I’m not that familiar with the plasma ecosystem in Nixpkgs. Sorry. But, it’s interesting that nix-locate (https://github.com/bennofs/nix-index) haven’t found any of this .cmake files the build reports as missing in all of Nixpkgs.