--unpack option to nix-prefetch-url not working

I am having a problem with the --unpack option with nix-prefetch-url. When I provide it with the following github link: “https://github.com/xorg62/tty-clock/archive/refs/tags/v2.2.zip

But I am only getting this output:
[0.0 MiB DL] adding 'https://github.com/xorg62/tty-clock/archive/refs/tags/v2.2.zip' to the store

I have tried it with other github links, but it still does the same thing. I have also tried both the .zip version, and .tar.gz version. This happens on both my work-station and laptop.

So for some reason it is not downloading. I am guessing that DL stands for Down-Loaded. The command nix-prefetch-url is capable of downloading things, but only when the --unpack option is not provided. Here is the full command I ran:
nix-prefetch-url --unpack https://github.com/xorg62/tty-clock/archive/refs/tags/v2.2.tar.gz

I have also confirmed that there is no download happening with btop++.

I am running OpenSUSE leap 15.6, and I am on an X86 platform.

So I am at a lose for why this is happening, I first noticed this when I was following the tutorial at nix.dev when I noticed that when I tried to get the hash for icat.


Note: I tried the command on a virtual machine running NixOS, and the --unpack option works there. So I am assuming that this has something to do with OpenSUSE. I still do not really know.