Unwanted vim in /nix/var/nix/profiles/default path

After installing vim package via vim_configurable.customize, I noticed that another vim was higher in my path. Output of which -a vim:

/nix/var/nix/profiles/default/bin/vim
/run/.../vim   <- desired custom vim

I don’t know how the profiles/default vim got there, but I would like to remove it so that my custom vim is first in the path.

I tried removing the vim from my configuration.nix but the profiles/default version remains, so it appears unrelated. I have rebuilt, switched and rebooted.

Any tips on how to remove this vim or at least force the installed package higher in the PATH hierarchy?

Did you set programs.vim.enable = true?
That adds the regular vim to your path. See here.

I believe that setup requires Home Manager. I had previously installed Home Manager and set it to true, and then deleted it and Home Manager (and rebuilt, switched and rebooted) in favor of the customizable vim. It appears to have not been removed after deleting that line (along with other Home Manager lines).

Make sure to nix-env -e home-manager-path after uninstalling home-manager, if you haven’t done so already.

Thanks for your suggestion @manveru. I have run the command to uninstall home-manager-path and it appears to have no effect.