VM freezes debugging

I run a Vmware VM with NixOS 22.05. I recently started to experience freezes with it.

Actually I used to have NixOS 21.11 and started to expereince freezes after using the VM for more than 6 months without issues. Eventually I found out I run out of disk space (50GB were full). So I created another VM with 22.05 with enough free disk space hoping the probelm will disappear. It didn’t.

There is nothing in the logs when the freeze happens. It takes about 25 minutes from boot to experience the freeze. The VM stops being responsive, the host CPU goes up. The VM can still be pinged, but I can no longer SSH to it. There is nothing in the Vmware Workstation logs. The VM has more than 25GB RAM allocated, 120GB disk and 6 CPUs. I increased the syslogd log level hoping to find anything in the journal or in dmesg, but without any luck.

I use the VM for development on Windows. It has some dev tools installed, but nothing special. I couldn’t associate the problem with any of the packages I use - the freeze happens regardless if open anything or not.

Any help will be appreciated.

Have you tried using a non-NixOS VM to confirm the problem is actually in the VM? This sounds more like a host issue, especially given the lack of logs

Given windows host, this might not be the right forum. My immediate thought would be overzealous antivirus, as is so common there.

Thanks for your reply @TLATER.

Since I wrote the above I decided to start the VM with an empty home dir and the problem is gone. I suppose the lack of disk space corrupted some file I’m yet to find out which one.

It was very helpful to me to share the problem here. Thanks forum for the listening!

1 Like