Where do I report this bug?

I enabled Wayland in my NixOS configuration. In GDM, it appears selected by default, but when I sign in, it is actually an X session. I need to click on the Wayland option in GDM (that appears to be selected) in order to log into a Wayland session.

Do you think this is a NixOS specific bug, or an upstream issue? I have no idea what my reproduction steps would be. It reminds me of the green text memes:
step 1.
image

There is no wayland option for GNOME, only for GDM, and it is enabled by default. But it only serves to allow GDM to run in Wayland when the system (mainly GPU drivers) supports it.

The session chooser should only contain GNOME and GNOME Xorg options, where the former will try Wayland (if supported) and fallback to X when it fails. But whatever is selected should be used, even without clicking anything.

You can try looking at the system journal after enabling the debugging with:

services.xserver.displayManager.gdm.debug = true;
services.xserver.desktopManager.gnome.debug = true;
1 Like