Why is my lastpass-cli not the newest version?

$ lpass --version
LastPass CLI v1.3.4.GIT

but https://github.com/NixOS/nixpkgs/blob/5632ccb7f5d6e594d01070096d8742a0f8e78d40/pkgs/tools/security/lastpass-cli/default.nix says: version = "1.3.6";

I need the newest version for the updated SSL certs. :confused:

$ nixos-version
23.05.4662.34bdaaf1f0b7 (Stoat)

What do you recommend?

Are you on 23.05-stable or unstable channel? 23.05 has 1.3.4, while unstable (which is what you’re seeing on github) has 1.3.6.


Gosh you are wildly helpful! Thank you so much for your time and energy!

I’m on stable. Should I just add unstable and use unstable.lastpass-cli? I read about that somewhere.

It’s been months since 1.3.4 has worked! Is this just a symptom of the speed of updates, or could I help expedite the update? What do you think is best practices here, personally, and community-wise?

Also, how did you know that that link went to unstable? I couldn’t find any indication either way. :confused:

To fix your immediate problem, yes. Should be easy to do with nix-env.

Let’s see, the PR to update lastpass-cli is this one. PRs are only merged to master and later deployed to unstable by default.
So what you need to happen is for this change to be backported to 23.05. This section in the contribution guide describes how to do it.
I guess it wasn’t done here because nobody thought a minor update could be so critical. So yes, if you don’t get the ball rolling, the backport won’t happen.

I think the most important factor is to reduce the mental workload for the maintainers. While you could manually backport the PR yourself (and that might be a good learning experience), the easiest way would be for a nixpkgs maintainer to add a backporting label to that PR, as described in the link above. This makes the backport happen automatically, and is less work than reviewing a PR.

From my experience, there is very little official procedure in nixpkgs (and the nix community in general), so I would say you can just write a quick comment in that PR tagging the the person that merged it and ask them to do it. It should be a task of a few seconds, as far as I understand.

Normally you should tag the maintainer of the package, but this one is now orphaned.

I checked on search.nixos.org. This searches the channel directly. What you see on GitHub is only a temporary snapshot, and it takes a long time (multiple days, I think), for all changes on master to be built and available for download from the cache.

But with GitHub in general, the simplest way is to just look at the file you’re interested in on multiple branches. Following the link you posted, I see this:

The hash next to “last month” is the last commit that was made to this file on the current branch. The branch is shown in the upper left corner, and it is the hash of the current commit we’re looking at. You most likely got this by clicking “copy permalink” somewhere.

If I click on that dropdown in the upper left corner and select “master”, I see this:

The branch we’re looking at now is master, but the commit we see hasn’t changed. However, when I go to the drop-down again, search for “release-23.05” and click that, I see this:

Now we see a much older commit, but it’s the latest one this file was change in on the “release-23.05” branch. So you know the newer one isn’t on this branch.

1 Like

Hoping to save @iFreilicht some time (he’s also helped me in the past)…

Part of the answer to this is in the commit you linked to above (default.nix) - which is removing the maintainer of the package.

1 Like

Thanks so much for y’all’s patience with my reply. I do not take your copious support for granted!

I would love some direction in testing the backport if at all possible. I’m really excited to get reliably good at this stuff!

(@iFreilicht you very generously asked me to tag you, though I suppose it may be past bedtime where you are.)

Correct, but it’s daytime now, so let’s do this. First off, you’ll have to clone the nixpkgs repo. If you didn’t do this already, I would recommend using --depth=1 to download as little as possible. The nixpkgs repo is humongous.

Then, cd into the nixpkgs directory and run this command:

nix-shell -p nixpkgs-review --run "nixpkgs-review pr 265657"

The PR number is the one of the PR you want to test. This command will put you in a nix-shell with the new version of lastpass-cli from that branch:

[nix-shell:~/.cache/nixpkgs-review/pr-265657]$ which lpass
[nix-shell:~/.cache/nixpkgs-review/pr-265657]$ lpass --version
LastPass CLI v1.3.6.GIT

The hash won’t match on your PC because I’m on macOS, but the version absolutely should.

Now you can just try it out and see if it works as you expect :slight_smile:

1 Like

Thank you thank you thank you!!

It worked! I’m logged in!!!

Awesome! One final thing; to make it more obvious that the PR has been approved by you, you should mark it as approved by going to “Files changed”, clicking on “Review changes”, marking the radio button “Approve” and then clicking “Submit Review”.

You already explained what you did, so you can leave the comment field empty.

I could of course do it as well, but it’s better (and more ~correct) to see at a glance who actually checked the changes.

1 Like

ah! Thank you so much! Done

Great! Congratulations on your first contribution. Might not feel like much but every bit of help is appreciated, and this wouldn’t have been fixed without you :slight_smile:


you’re amazing! it feels great! I look forward to more

1 Like

…when might it merge with nixos-23.05? :laughing:

IT’S IN! I’m so happy my stuff works again!! Thanks again to everybody who helped!!!