xkbOptions = "bksp:nocaps" not working

I would like to change the functionality of my CapsLock key to BackSpace.

In configuration.nix i have

  services.xserver = {
    enable = true;
    layout = "de";
    xkbVariant = "nodeadkeys";
    xkbOptions = "bksp:nocaps";

Running cat /etc/X11/xorg.conf.d/00-keyboard.conf yields

Section "InputClass"
  Identifier "Keyboard catchall"
  MatchIsKeyboard "on"
  Option "XkbModel" "pc104"
  Option "XkbLayout" "de"
  Option "XkbOptions" "bksp:nocaps"
  Option "XkbVariant" "nodeadkeys"

However, even after reboot the CapsLock key functions as CapsLock and not as BackSpace. This although the Xorg Documentation has as an example “terminate:ctrl_alt_bksp”, so bksp should be the correct way to adress the BackSpace functionaility.

“ctrl:nocaps” works fine for me but i would prefer “bksp:nocaps” if possible.

Does someone know how to do it?

According to man xkeyboard-config, I believe it’s caps:backspace.

1 Like

Indeed, that works. Thank you! :slightly_smiling_face: