0ad segmentation fault, core dumped

İ cant play 0ad. thanks to segmentation fault, core dumped error. İm on Wayland Wayfire WM. How to solve it.

Do you have any more details? I’m the maintainer of the package and play the game regularly without issues. Note that you can’t use 0ad from nixos-unstable if you’re on nixos-22.05 (or vice-versa), because your graphics stack has to match the system.


@chvp ty for quick answer but i dont have any other info. Urban Terror works for example , yes i am on 22.05, I will reboot and try again.

If the reboot doesn’t fix it, I’ll see if I can spin up a 22.05 VM and try to reproduce the segfault. I probably won’t have time to do so in the near future though.

1 Like

After the reboot, is there any output if you try to run it from a terminal?

What exact commit of nixpkgs are you on?

1 Like

İ am updating packages. May be it helps. İ tried anything but i fail. @chvp @NobbZ how to learn exact commit of nixpkgs i am on ?

Most of the time nixos-version will tell you.

If though you are not installing 0ad via the systems configuration, but another way, we need to need to know more about how you installed and updated it exactly.

1 Like

22.05.926.8b538fcb329 (Quokka)
i have used configuration.nix. To update i typed doas nixos-rebuild switch --upgrade

I ran into this issue because I used zeroadPackages.zeroad-unwrapped instead of simply using zeroad from nixpkgs.

nix-shell -p zeroad --run 0ad works for me.