1Password CLI 'authorization prompt dismissed' error

I’m trying to get the 1Password CLI working (so I can integrate it with Qutebrowser) but when I try to login I get a popup saying "1Password is trying to authorize CLI access to your account “…” in “…”, but when I click Allow Access I get:

[ERROR] 2023/06/12 09:44:24 authorization prompt dismissed, please try again

I think this is something to do with polkit? I’m running Hyprland from their official flake, which should include polkit. I’ve also tried manually enabling polkit in my configuration.

Let me know if there’s more relevant info I can provide.

Here is what I am using for 1password.

{ config, pkgs, ... }:
  # {imported to configuration.nix direct as home-manager does not support 1password
  programs._1password = { enable = true; };

  # Enable the 1Passsword GUI with myself as an authorized user for polkit
  programs._1password-gui = {
    enable = true;
    polkitPolicyOwners = [ "dustin" ];

I just installed the CLI, and logged in. ran op item list as a test.

I had one prompt (see screenshot). Oddly it did not take my password and errored out. Then I just ran the command and it started working,

I’ve done the same (switching out the username) and unfortunately get the same error, but now without any GUI prompt at all. Was there anything more to do to set up polkit perhaps?

Do you have polkit/keyring setup in it’s entirety?

I had lots of prompt issues until I did that. how have you configured polkit itself?

Sorry for the delayed reply, I somehow missed your response.

Currently I simply have security.polkit.enable = true, and polkit-kde-agent package installed.

The Hyprland docs (https://wiki.hyprland.org/Nix/Hyprland-on-NixOS/) state that the module enables polkit too.

If you could share your relevant config that would be really appreciated—I’ve not had to touch this before (can you tell :sob: ).

My repo can be found at GitHub - bashfulrobot/nixos-hyprland

Hope it helps.