Airline/powerline in neovim not working/not showing glyphs

I have put all the following in my configuration.nix package list:


I have used vim-plug to install:

Plug 'powerline/powerline'
Plug 'vim-airline/vim-airline'
Plug 'vim-airline/vim-airline-themes'
Plug 'ryanoasis/nerd-fonts'

The powerline attempts resulted in absolutely nothing. no changes to nvim.

airline now shows this:

What am I doing wrong? what am I missing?

Now I’m finding that powerline also can work for zsh and tmux and I would really love a unified look across three of the places where I spend most of my time.

This is all pretty extra, but now I’m getting really invested in it.

I suspect you still need to tell your console which font it should use, with the console.font option.

I think the console font is just for the actual Linux console, not for terminal emulators and such, right?

It may be that the fonts need to be installed via the fonts.fonts option in configuration.nix. That’s my setup and it’s working.

none of that seems to have helped. :confused: If you need more info, I may be able to provide some in a few hours.

What terminal are you using?

Thanks for asking! urxvt

Have you tried setting the desired font in the config for urxvt?

1 Like

I just spent way too long trying different fonts in xresources and the fonts changed, but no glyphs and still messy stuff in airline

okay, I somehow got it working. I added a bunch of lines to explicitly define the glyphs in my vim config. and I tried a bunch of fonts until one rendered all of the glyphs. I landed on Deja Vu Sans Mono for Powerline. :woman_shrugging: It’s working! The last character that I got going was the character number character. took a bunch of fonts to get one that rendered that. but honestly, I don’t know if it was the font itself that fixed it. if somebody else has trouble with this down the line, feel free to revive the thread and I’ll post/go through my config. <3

I have the same issue, albeit with lualine. Nerdfonts are installed on the system but neovim just doesn’t use them. I would really appreciate if you could share your config.