All connections (wifi, ethernet, bluetooth) fail


I’ve been running Nixos successfully on a Thinkpad T480 since January. However, this morning, my device started refusing to connect to any site whatsoever. Connecting to e.g. a router works fine, and nmcli lists my connection state as full, but no hostnames (or ip addresses) resolve. Given that I can’t install new software, can anyone offer advice on how to debug this?

I’m on nixos-unstable. The only possible symptom I’ve noticed is that sudo journalctl -b | grep -i "net\|dns\|resolv" surfaces a message about ‘dbus-org.freedesktop.resolve1.service’ not being found, but I don’t think I’ve ever had that installed.

Things tried:

  • Different connection types (wifi, ethernet, network via bluetooth).
  • Connecting with different devices to isolate issue to my laptop.
  • Rollback to a configuration from two weeks ago.
  • Manually modify /etc/resolv.conf nameserver to and
  • Reboot device.
  • Reboot router.
  • sudo systemctl restart NetworkManager
  • nmcli radio wifi off/on
  • manually edit /etc/sysctl.conf to disable ipv6
  • Check iptables for REJECT lines
  • Check ip addr show
  • Connect to local devices, e.g. (fails).

So I am officially out of ideas :sweat:, any suggestions would be highly appreciated :pray:. Thanks!

Github issue with workaround that worked for me here: services.mullvad-vpn wipes out all network access · Issue #314694 · NixOS/nixpkgs · GitHub. tl;dr: Disable services.mullvad-vpn.