Apfs kernel module (and others) build fails for most kernel versions (but not all)

Since several months I have been getting build errors for kernel modules which I occasionally rely on:

  boot = {
    kernelPackages = unstable.linuxPackages_zen;
    # kernelPackages = pkgs.linuxPackages_6_3;
    # kernelPackages = unstable.linuxPackages_5_15;
    # initrd.kernelModules = [ "amdgpu" ]; # for reasonable console graphics mode # now via HW module
    extraModulePackages = with config.boot.kernelPackages; [ /* apfs */ zenpower ddcci-driver ]; # some of these modules sometimes don't build for different versions (unpredictable)

Recently, at least apfs worked on linux_6_2, but since that got removed since 23.05 got out of beta, I figured I just use linux_6_3 (or linux_zen) but it gives me again the same error I had in e.g. in linux_zen-6.1.x:

error: builder for '/nix/store/5fb008yjdzfmgjkvfp6rsy2fr4gh6f1h-apfs-0.3.1-6.3.4.drv' failed with exit code 2;
       last 10 log lines:
       >       |                           ^~~~~~~~~~~~
       > /build/source/file.c:162:27: note: (near initialization for 'apfs_file_inode_operations.setattr')
       > /build/source/file.c:166:27: error: initialization of 'int (*)(struct mnt_idmap *, struct dentry *, struct fileattr *)' from incompatible pointer type 'int (*)(struct user_namespace *, struct dentry *, struct fileattr *)' [8;;https://gcc.gnu.org/onlinedocs/gcc/War
       >   166 |         .fileattr_set   = apfs_fileattr_set,
       >       |                           ^~~~~~~~~~~~~~~~~
       > /build/source/file.c:166:27: note: (near initialization for 'apfs_file_inode_operations.fileattr_set')
       > cc1: some warnings being treated as errors
       > make[2]: *** [/nix/store/bqpz3gm0ad93j4gcwk7cjsip68mq27sl-linux-6.3.4-dev/lib/modules/6.3.4-zen1/source/scripts/Makefile.build:252: /build/source/file.o] Error 1
       > make[1]: *** [/nix/store/bqpz3gm0ad93j4gcwk7cjsip68mq27sl-linux-6.3.4-dev/lib/modules/6.3.4-zen1/source/Makefile:2023: /build/source] Error 2
       > make: *** [Makefile:17: default] Error 2
       For full logs, run 'nix log /nix/store/5fb008yjdzfmgjkvfp6rsy2fr4gh6f1h-apfs-0.3.1-6.3.4.drv'.
error: 1 dependencies of derivation '/nix/store/37pdypwhii5ryrd11j3h95l05bwysils-kernel-modules.drv' failed to build
error: 1 dependencies of derivation '/nix/store/qd36sdik0q6fzviy7anqibil774sa4ry-linux-6.3.4-modules.drv' failed to build
error: 1 dependencies of derivation '/nix/store/lka8k4vk7yk116qjfq3bzav26h42d3xd-nixos-system-jnixryz-23.05.20230531.3a70dd9.drv' failed to build

It confuses me that the same (or similar) errors (since kernel 5.11 up to 6.3) don’t happen for a few versions but keep coming back?

Searching for similar errors didn’t turn up anything, which is even more confusing, since such errors are most likely to be upstream and should have been detected there, no?