Applications not darkmoding properly in bungie desktop

Hello hello! I just installed nixos so I’m pretty much brand new, anyway, for some reason my applications arent ‘darkmoding’ properly, for instance, keepassxc and audacious are light mode by default, and in the case of audacious and firefox(Keepassxc doesn’t have appearance settings) even if I set it to dark mode in the app settings parts of it will still be set to light mode(Song lists and main bar on audacious, search bar area on firefox). Anyone know a fix?

I haven’t really tweaked budgie after installing nix at all, aside from enabling the dark mode.

I believe those are all gtk applications, or at least applications that will listen to gtk settings (except keepass, maybe?).

Anyway the problem (as usual in Linux land) is that there are multiple competing window toolkits, and each uses a different configuration file, which needs to be individually set to do “darkmoding”. Most of the time, configuring both gtk and Qt to use dark mode will be sufficient, though additional individual applications will often need more attention.

Some distros do this work for you, NixOS does not currently. At least until freedesktop decides to create a standard for this, then maybe in a decade or two you will only need to configure the freedesktop standard and one or two additional legacy applications.

Anyway, in practice for now if you set up a dark gtk theme (warning, home-manager config, I don’t think such config exists for NixOS), gtk will automatically set dark mode in most applications, including Firefox (? at least it does for me). The fact that some of your applications are stuck in a “light” mode is probably because you have a light gtk theme set.

It does: