Autoupgrade can't resolve host name

I have automatic upgrades set up and it worked great for a while, then silently stopped updating due to a URL change. This was a while back, so I don’t remember exactly what that was. But I got it fixed and the updates worked again for awhile but then started silently failing again. Now every morning I get messages like this in the logs:

warning: error: unable to download '': Couldn't resolve host name (6); retrying in 293 ms

However I can load that URL just fine in a browser and the tar starts downloading. Anyone have any idea why just the auto-updates daemon wouldn’t be able to resolve this URL?

Weird. Then this morning it tried twice and couldn’t resolve the host but then worked on the third try. I don’t think I’ve ever heard of intermittent DNS resolution issues like this… although actually, ever since I set up NixOS on this machine, every once in a while the browser can’t resolve pages and I have to quit and restart. So this seems to have nothing to do with autoUpgrade but is some weird issue with my DNS. More spelunking… yay.