Basic config hides display from applications

At my current generation, all my applications function and run correctly. I have not setup flakes yet. However, when I rebuild my config with the flake config linked below, any application that requires GUI falls apart; which is basically everything. (including restart/shutdown buttons in my plasma desktop)

Config: GitHub - GetPsyched/homeless-shelter: my nix config


When I run konsole in my VSCode terminal (which I ran before testing my new config else vscode wouldn’t launch either), I get the following error:

No protocol specified
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Aborted (core dumped)

Narrowed down the issue to networking.hostName = "nixos";. Changing the hostname causes this issue somehow. Probably something to do with Plasma.