Boot error due to bad path in stage 2

Hello, I wanted to update one of my servers in hetzner running NixOS but the new configuration is failing to boot up. The boot error seems to be due to a bad path, it’s trying to access /mnt-root//nix/store/<hash>. I think the double slash is the issue because booting back into the previous generation I can see that the nix store path exists on the disk.

I’ve tried garbage collecting the new generation and rebuilding from scratch but I got the same boot error. I’ve also tried upgrading this system to latest nixpkgs/nixos-23.05 but I still got the same error. This server is using disko for disk management and a Btrfs root. You can see the config here.

I’ve looked around and couldn’t find a similar issue reported elsewhere (on this forum or github issues). Any idea what might have caused the bad path and how to fix it?

Solve the issue. Some time ago Disko started requiring that Btrfs subvolumes have a mountpoint set (previously the mountpoint would default to the subvolume name, ie subvolume /nix would mount at /nix).