Boot fails when trying to mount /home

Hello! I’m pretty new to NixOS and Nix at all and I’m trying to install from zero the system.

I followed the manual and also searched a lot about how to install and finally got to the end of installation when I am prompted to give a new root password.

So I rebooted and the system logs me in the emergency mode and say to look into journalctl.
Ok, this is what I found:

All my config can be found in my repository:

What I’m supposed to do? I also tried to remove home-manager but error stills happening.

1 Like

Your link is dead and I don’t find anything under but it seems like your hardware-configuration.nix has a wrong mountpoint for /home.


Welcome! Installing nix for first time can be a little daunting , but fear not , we can help you. I can’t find your configuration file , but i presume your refactoring your configuration.

Your git page is quite cool!

So welcome…we can get you up and running!

1 Like

Sorry, I refactored it and deleted from dotfiles for now.

But yeah! Somehow the hardware-configuration.nix generated the wrong config for my disks.
Ok I’ll not blame Nix because is most likely to happen a personal error!

Thanks for your response and sorry about my vanishment haha

Yeah! But I really liked the idea to declare my distribution and then have isolated environments which I can install/remove/rollback software the way I want in a such stable distro.

Wow. I’m onlly using for some hours but I’m really happy with the actual state. I need to get used to about installing haskell packages (some are broken) and I really need them, like xmobar (ok, that isn’t broken but I couldn’t set up :confused: but patat is one I really like but is broken).

The most important thignis that was fun to write nix! No awful manual Linux configs (:

1 Like

Thanks! Do you have a github/gitlab user? What it is?

yeah, i seem to remember, there was an issue on older machine of mine, which has normal non-uefi boot, and a slightly buggy uefi boot loader (i think they are all slighty broken in bizzare ways). It was a matter of selecting the way to reference my disk…lucky/unlucky for you linux gives you many many options of referencing disks… on /dev/disk/ by-id by-label by-partlabel by-partuuid by-path by-uuid

so nixos-generate-config got it wrong, so i had to manually edit it, but i think it was mainly down to a buggy uefi bios… again, i was switching from uefi to non-uefi, which confused things even more.

I don’t have the machine anymore, and my later install, with a slightly less broken uefi boot worked a lot smoother.

1 Like

Exactly! I had the same problem!