Brother Printer not working

I am trying to use my Brother DCP-T420W Printer on linux but I can’t find any relevant drivers. So I tried packaging one myself, referencing one of the previous drivers and using it in configuration.nix as follows:

  # Enable CUPS to print documents.
  services.printing.enable = true;

  services.printing.drivers = [
    (pkgs.callPackage ./dcpt420w.nix {})

Can someone help me with this issue, I have tried almost everything at this point and don’t know what to do.

Did you enable the settings mentioned in the Wiki?

1 Like

On the wiki I found I only need to have services.printing.enable = true; which I have enabled in my nixos config

Per about configuring Brother DCP-T420W / Newbie Corner / Arch Linux Forums you can use IPP Everywhere (i.e. a driverless setup) for this printer. (Though I don’t see it listed under About AirPrint - Apple Support (CA) so I can’t confirm this myself.)

Driverless setup (network printing requires the following configuration:

services = {
  avahi = {
      enable = true;
      nssmdns4 = true;

  printing.enable = true;

Then sign into CUPS (http://localhost:631/admin) using your account’s username/password, and add your printer there, ensuring to not select a driver, but IPP Everywhere instead.

I tried this but I don’t think it worked. I don’t have access to the printer anymore so I can’t try again : (