Bug: gnome3 not working after trying pantheon

#1

I wanted to test the pantheon DE from unstable nixpgs. I got only a black screen after login. So I set my DE back to gnome3 (my previous configuration.nix). However now gnome3 only shows me a white xterm in the upper left corner, no menus, no bars, nothing but this terminal.
My configuration.nix is the same as it was before I tried pantheon.

I remember I got some “collision” warnings installing pantheon. What are these? Could this cause the problem?

Booting an old config from grub works. What can I do now?

#2

Hello, I maintain Pantheon in nixpkgs.

There’s been a similar issue in https://github.com/NixOS/nixpkgs/issues/57327.
For me to help I’d need similar logs as requested there.

I’d also need to see your effective configuration.nix and know what nixpkgs revision you’re at.
Running the following should provide that.

nix-shell -p nix-info --run "nix-info -m"
#3

Also just for fun please try disabling their greeter

services.xserver.displayManager.lightdm.greeters.pantheon.enable = false;
#4

sudo nix-shell -p nix-info --run “nix-info -m”

  • system: "x86_64-linux"
  • host os: Linux 4.14.104, NixOS, 19.09pre171945.b36dc66bfea (Loris)
  • multi-user?: yes
  • sandbox: yes
  • version: nix-env (Nix) 2.2
  • channels(root): "nixos-19.09pre173147.03050e9749e, nixpkgs-19.09pre173147.03050e9749e"
  • channels(zeec): ""
  • nixpkgs: /nix/var/nix/profiles/per-user/root/channels/nixos
#5
# Edit this configuration file to define what should be installed on
# your system.  Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running ‘nixos-help’).

{ config, pkgs, ... }:

{
  imports =
    [ # Include the results of the hardware scan.
      ./hardware-configuration.nix
    ];

  # Use the GRUB 2 boot loader.
  boot.loader.grub.enable = true;
  boot.loader.grub.version = 2;
  boot.loader.systemd-boot.enable = true;
  boot.loader.grub.efiSupport = true;
  boot.loader.grub.efiInstallAsRemovable = true;
  #boot.loader.efi.efiSysMountPoint = "/boot/efi";
  # Define on which hard drive you want to install Grub.
  boot.loader.grub.device = "nodev"; # or "nodev" for efi only

  networking.hostName = "nixos"; # Define your hostname.
  #networking.wireless.enable = true;  # Enables wireless support via wpa_supplicant.
  networking.networkmanager.enable = true;

  # Set your time zone.
  time.timeZone = "Europe/Berlin";

  # List packages installed in system profile. To search, run:
  # $ nix search wget
  

  environment.systemPackages = with pkgs; [
      wget 
      vim
      google-chrome
      firefox
      alacritty
      fish
      (vscode-with-extensions.override {
      vscodeExtensions = with vscode-extensions; [
        bbenoist.Nix
      ];
      })
      pantheon.elementary-terminal
      git
      htop
      imagemagick
      veracrypt
      steam
      vlc
      tdesktop
      skype
      spotify
      albert
      #acrobat-reader
      wine-staging
      winetricks
      borgbackup
      #insync
      neofetch
      nix-index
      libreoffice
      texstudio
      texlive.combined.scheme-full
      gimp
      subversion
      gparted
      unzip
      ripgrep
      cudatoolkit
      cudnn
      (python37.withPackages(ps: with ps; [ numpy ]))
      jetbrains.pycharm-community

      arc-theme
      arc-icon-theme
      numix-icon-theme
      gnomeExtensions.dash-to-dock
  ];

  # Some programs need SUID wrappers, can be configured further or are
  # started in user sessions.
  # programs.mtr.enable = true;
  # programs.gnupg.agent = { enable = true; enableSSHSupport = true; };

  # List services that you want to enable:

  # Enable the OpenSSH daemon.
  services.openssh = {
    enable = true;
    permitRootLogin = "no";
    passwordAuthentication = false;
  }; 

  # Open ports in the firewall.
  # networking.firewall.allowedTCPPorts = [ ... ];
  # networking.firewall.allowedUDPPorts = [ ... ];
  # Or disable the firewall altogether.
  # networking.firewall.enable = false;

  # Enable CUPS to print documents.
  # services.printing.enable = true;

  # Enable sound.
  sound.enable = true;
  hardware.pulseaudio.enable = true;

  # Needed for steam
  hardware.opengl.driSupport32Bit = true;
  hardware.pulseaudio.support32Bit = true;

  # docker
  virtualisation.docker.enable = true;

  # Enable touchpad support.
  # services.xserver.libinput.enable = true;

  services.xserver.enable = true; 
  services.xserver.layout = "us"; 
  services.xserver.displayManager.lightdm.enable = true; 
  services.xserver.desktopManager.pantheon.enable = true;
  services.xserver.videoDrivers = [ "nvidia" ]; 
  

  # Define a user account. Don't forget to set a password with ‘passwd’.
  users.users.zeec = {
     isNormalUser = true;
     uid = 1000;
     home="/home/zeec";
     extraGroups = ["wheel" "networkmanager"];
  };

  programs.fish.enable = true;
  users.extraUsers.zeec = {   
    shell = pkgs.fish;
  };
  
  # Fonts
  fonts = {
    enableFontDir = true;
    enableGhostscriptFonts = true;
    fonts = with pkgs; [
      corefonts # Microsoft free fonts
      inconsolata # monospaced
      font-awesome-ttf
      freefont_ttf
      opensans-ttf
      liberation_ttf
      liberationsansnarrow
      ttf_bitstream_vera
      libertine
      ubuntu_font_family
      gentium
      symbola
      noto-fonts
      noto-fonts-cjk
      noto-fonts-emoji
      liberation_ttf
      fira
      fira-mono
      fira-code
      fira-code-symbols
      mplus-outline-fonts
      dina-font
      proggyfonts
    ];
  };

  nixpkgs.config.allowUnfree = true;
  system.stateVersion = "18.09"; # Did you read the comment?
 }
#6

@ worldofpeace
Thanks,
services.xserver.displayManager.lightdm.greeters.pantheon.enable = false; helped. I then removed the option again and pantheon still works.

Thanks for maintaining pantheon.

1 Like