Cannot mix incompatible Qt library error?

Here is my simple flake.nix

  description = "A very basic flake";

  inputs = {
    nixpkgs.url = "nixpkgs/nixos-21.11";

  outputs = inputs@{ self, nixpkgs, ... }: 
    pkgs = import nixpkgs {
      system = "x86_64-linux";
      config = { allowUnfree = true; };
    packages.x86_64-linux.mathpix = pkgs.mathpix-snipping-tool;

    defaultPackage.x86_64-linux = self.packages.x86_64-linux.mathpix;


When I run nix run, the following error happens.

Cannot mix incompatible Qt library (5.15.3) with this library (5.15.2)
[7:7:20220527,145150.604102:ERROR elf_dynamic_array_reader.h:61] tag not found
[7:8:20220527,145150.702483:ERROR] SSL_connect
[7:8:20220527,145150.702511:ERROR] SSLStream Initialize

When I do nix-store -qR /run/current-system | grep qt to find qt in /nix/store, I can spot qtbase-5.15.3 and related paths but nothing related to qtbase-5.15.2. And from nix-store -q --referers /nix/store/path-to-qtbase-5.15.3, it seems that qtbase-5.15.3 is used by plasma desktop environment.

Is this the cause of the problem? If so, then there might be 2 possible solutions.

  1. Override qtbase

Q. how do I override the minor version from qtbase-5.15.2 to qtbase-5.15.3?

  1. Fix the original src

Q. mathpix-snipping-tool's src is fetched by appimageTools.wrapType2. In nix develop, I tried the unpackPhase but failed with error variable $src or $srcs should point to the source. How is the file delivered?