Can't get Distrobox to work

Hi there! I am struggling with Distrobox, because I am not able to run the containers. I use Podman, but this happens also with Docker. I can run normal containers like Arch without any problems. This is only an issue with Distrobox. I am not very experienced with containers or NixOS, so any ideas are very much appreciated!

[simon@nixos:~]$ distrobox-create --name Arch --image  
Creating 'Arch' using image   [ OK ]  
Distrobox 'Arch' successfully created.  
To enter, run:  
distrobox enter Arch  
[simon@nixos:~]$ distrobox enter Arch  
Container Arch is not running.  
Starting container Arch  
run this command to follow along:  
podman logs -f Arch  
Error: unable to start container "a37c4c77c8b14f4970cf3bea01432fa14da79f0e14fc1925fc7fa1ae1b397731": cr  
un: make `/home/simon/.local/share/containers/storage/vfs/dir/a6d27ced181b26285884257ffec9104071f3d1370  
3de0c5e3a14a2b9dfed30ed` private: Permission denied: OCI permission denied  

Check your permissions on ~/.local/share/containers. I tried it on both a NixOS system and Fedora system using Nix (flakes) and it worked both places.

You may also have to reset podman if you’ve changed the storage backend (be careful you don’t lose any volumes that you have data in).

1 Like

Indeed it was a problem with permissions somewhere in ~/.local/share/containers. Thank you very much :heart: