Cant get NixOs boot after install

Hello. Tried every tutorial and install of nvidia graphics, putting them into config file etc with 0 results. every time i boot my nixos it hangs with underscore flashing so its a graphic card drivers issue

i have NVIDIA 4070 super

Can somene provide me with configuration.nix file that will work out from the box with this graphic card ? My Intel i5 13400f doesnt have a build in graphic.

And can you expalin how live usb have GUI and after install its not booting the same way ?

1 Like

Hello :wave:

Have you tried the RTX SUPER on NixOS stable config from the Wiki? From what I see there, you need to add a special config for the 4070 SUPER to work.

The live USB system loads graphics normally because it uses the open source nouveau drivers (which don’t need configuration) and not the proprietary Nvidia drivers.

In this regard, you could try not installing the proprietary drivers and see if your system boots normally.

Got it all working

Instructions for others that had the same issue:
when you see underscore flashing press


type login you made durring instalation and password
then type

cd /nix/nixos

sudo nano configuration.nix

add command under X11windowing:

services.xserver.videoDrivers= ["nvidia"];

save the file, then type

sudo nixos-rebuild switch

and after everything install type


and it will boot into GUI

1 Like