Can't get rid of Perl locale warnings at any unknown command

pretty new to nixOS and generally like a lot of things about it. Some errors that I get are super-weird in general though. like this one. whenever I type any command that is not known, I get PERL warnings like this:

[f13r@f13r:~]$ test123
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_MONETARY = "en_IE.UTF-8",
        LC_MEASUREMENT = "en_IE.UTF-8",
        LC_TIME = "en_DE.UTF-8",
        LC_NUMERIC = "en_IE.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
test123: command not found

My nixOS flake contains only 1 entry regarding locales:
i18n.defaultLocale = "en_US.UTF-8";

So no idea how to get rid of this. If anyone has advice for me, I highly appreciate it!

1 Like